logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Lemonde  
#1 Posted : 13 December 2017 11:44:39(UTC)
Lemonde

Rank: Advanced Member

Groups: Registered
Joined: 08/01/2017(UTC)
Posts: 137
United Kingdom
Location: London

We are seeing the following from the connectivity tester:


Testing inbound SMTP mail flow for domain 'recipient@domain.suffix'.
The Microsoft Connectivity Analyzer failed to test inbound SMTP mail flow.

Additional Details

Test Steps

Attempting to retrieve DNS MX records for domain 'domain.suffix'.
One or more MX records were successfully retrieved from DNS.

Additional Details
Testing Mail Exchanger myemail.domain.suffix.
One or more SMTP tests failed for this Mail Exchanger.

Additional Details

Test Steps

Attempting to resolve the host name myemail.domain.suffix in DNS.
The host name resolved successfully.

Additional Details
Testing TCP port 25 on host myemail.domain.suffix to ensure it's listening and open.
The port was opened successfully.

Additional Details
Analyzing SMTP Capabilities for server myemail.domain.suffix:25
SMTP Capabilities were analyzed successfuly.

Additional Details
Attempting to send a test email message to recipient@domain.suffix using MX myemail.domain.suffix.
Delivery of the test email message failed.

Additional Details

The server returned status code 451 - Error in processing. The server response was: 4.7.0 Temporary server error. Please try again later. PRX4
Exception details:
Message: Error in processing. The server response was: 4.7.0 Temporary server error. Please try again later. PRX4
Type: System.Net.Mail.SmtpException
Stack trace:
at System.Net.Mail.DataStopCommand.CheckResponse(SmtpStatusCode statusCode, String serverResponse)
at System.Net.Mail.DataStopCommand.Send(SmtpConnection conn)
at System.Net.Mail.SmtpClient.Send(MailMessage message)
at Microsoft.Exchange.Tools.ExRca.Tests.SmtpMessageTest.PerformTestReally()
Elapsed Time: 11387 ms.

We have manually changed the DNS on both the server OS and the Exchange ECP but nothing seems to work.
Sponsor
Lemonde  
#2 Posted : 13 December 2017 11:53:51(UTC)
Lemonde

Rank: Advanced Member

Groups: Registered
Joined: 08/01/2017(UTC)
Posts: 137
United Kingdom
Location: London

This actually appeared to be because the network switch the DNS servers were attached to had an issue and rebooted and the DNS servers decided they were no in an private network instead of a domain one and would not service DNS properly without rebooting both DNS and then the Exchange 2016 server.
Lemonde  
#3 Posted : 13 December 2017 12:05:20(UTC)
Lemonde

Rank: Advanced Member

Groups: Registered
Joined: 08/01/2017(UTC)
Posts: 137
United Kingdom
Location: London

Actually scrub that - the server works for a minute or so and goes back to:

The server returned status code 451 - Error in processing. The server response was: 4.7.0 Temporary server error. Please try again later. PRX4

I have checked:

DNS servers and entres
Time and Date
Certificates

But is still fails with PRX4 even after a restart of the server.

Edited by user 13 December 2017 12:21:19(UTC)  | Reason: Not specified

Lemonde  
#4 Posted : 13 December 2017 12:38:46(UTC)
Lemonde

Rank: Advanced Member

Groups: Registered
Joined: 08/01/2017(UTC)
Posts: 137
United Kingdom
Location: London

I wish I could tell you how to fix this - we did disable all inactive Network Interfaces and re-sync the time and reboot the DCs again and somehow it is fixed.

The time was a few minutes out from the correct time.

There were two unused NICs

Not sure why this would have suddenly become a problem after running so well for 18 months...
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.