Lemonde
  • Lemonde
  • Advanced Member Topic Starter
4 years ago
your computer can't connect to the remote computer because a security package error

Windows 10 error - I had an issue with Microsoft Edge which has now been resolved but my Windows 10 now reports an error when trying to use a remote desktop gateway server:

your computer can't connect to the remote computer because a security package error occurred in the transport layer. Retry the connection or contact your network administrator for assistance.

I can connect to local RDP computers no problem but when I try and use the remote desktop gateway I receive this error so presumably it is Microsoft Edge/Internet Explorer and SSL/TLS related.

Just to add that if you remove the tick box from the 'Allow connections only from computers running Remote Desktop with Network Level Authentication box on the destination computer, the problem is resolved:

UserPostedImage


Sponsor

Want to thank us? Use: Patreon or PayPal or Bitcoins: 12G4A52Znm5s35buKDEmKU2p2vQY69Nsyo

Protect your visitors with SSL, from $3.44

All opinions expressed within these pages are sent in by members of the public or by our staff in their spare time, and as such do not represent any opinion held by sircles.net Ltd or their partners.


Lemonde
  • Lemonde
  • Advanced Member Topic Starter
4 years ago
This issue was actually to do with saved authentication details for the remote desktop gateway under the connect from anywhere part of advanced tab under the RDP icon I was using.

I have deleted the credentials from the icon and now the conenction appears to work OK.

I had also run reg.exe Add "HKCU\Software\Microsoft\Terminal Server Client" /V "RDGClientTransport" /T REG_DWORD /D "1" from a command prompt with admin privileges


Lemonde
  • Lemonde
  • Advanced Member Topic Starter
3 years ago
Try deleting the credentials under the advanced tab:

UserPostedImage

Click settings under ‘Connect from Anywhere’

UserPostedImage

If there are any user name or password credentials stored here then delete them.