andrewt2m
11 months ago
Hello

We have an Exchange Server onsite and we are receiving an error when we try and send to our Office 365 recipients.

It is a hybrid set-up with Office 365 receiving the emails fine, just not from our Exchange server that seems to re-route the email back to the exchange server:

Delivery has failed to these recipients or groups:

recipient@domain.suffix

A problem occurred during the delivery of your message likely due to a bad mail routing configuration. This could be a temporary situation. Please try to resend the message later. If the problem continues, contact your email admin.

The following organization rejected your message: STOREsrv.domain.suffix.

Diagnostic information for administrators:

Generating server: EDGEsrv.domain.suffix

recipient@domain.suffix

STOREsrv.domain.suffix

Remote Server returned '554 5.4.12 SMTP; Hop count exceeded - possible mail loop detected on message id <1f4c13a46c164fdbbe497b034fbab3d2@yoush.it>'

Original message headers:

Received: from STOREsrv.domain.suffix (192.168.x.x) by EDGEsrv.domain.suffix

(192.168.x.x) with Microsoft SMTP Server (version=TLS1_2,

cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384) id 15.2.221.12; Tue, 24 Aug

2021 17:23:05 +0100

Received: from STOREsrv.domain.suffix (192.168.x.x) by STOREsrv.domain.suffix

(192.168.x.x) with Microsoft SMTP Server (version=TLS1_2,

cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384) id 15.2.922.7; Tue, 24 Aug 2021

17:22:33 +0100

Received: from EDGEsrv.domain.suffix (192.168.x.x) by STOREsrv.domain.suffix

(192.168.x.x) with Microsoft SMTP Server (version=TLS1_2,

cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384) id 15.2.922.7 via Frontend

Transport; Tue, 24 Aug 2021 17:22:33 +0100

Received: from STOREsrv.domain.suffix (192.168.x.x) by EDGEsrv.domain.suffix

(192.168.x.x) with Microsoft SMTP Server (version=TLS1_2,

cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384) id 15.2.221.12; Tue, 24 Aug

2021 17:22:33 +0100

Received: from STOREsrv.domain.suffix (192.168.x.x) by STOREsrv.domain.suffix

(192.168.x.x) with Microsoft SMTP Server (version=TLS1_2,

cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384) id 15.2.922.7; Tue, 24 Aug 2021

17:22:33 +0100

Received: from EDGEsrv.domain.suffix (192.168.x.x) by STOREsrv.domain.suffix

(192.168.x.x) with Microsoft SMTP Server (version=TLS1_2,

cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384) id 15.2.922.7 via Frontend

Transport; Tue, 24 Aug 2021 17:22:33 +0100

Received: from STOREsrv.domain.suffix (192.168.x.x) by EDGEsrv.domain.suffix

(192.168.x.129) with Microsoft SMTP Server (version=TLS1_2,

cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384) id 15.2.221.12; Tue, 24 Aug

2021 17:21:50 +0100

Received: from STOREsrv.domain.suffix (192.168.x.x) by STOREsrv.domain.suffix

(192.168.x.x) with Microsoft SMTP Server (version=TLS1_2,

cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384) id 15.2.922.7; Tue, 24 Aug 2021

17:21:50 +0100

Received: from STOREsrv.domain.suffix ([fe80::802d:f5f8:8d28:b8bf]) by

STOREsrv.domain.suffix ([fe80::802d:f5f8:8d28:b8bf%9]) with mapi id

15.02.0922.007; Tue, 24 Aug 2021 17:21:50 +0100

Content-Type: multipart/mixed;

boundary="_000_1f4c13a46c164fdbbe497b034fbab3d2_"

From:

To:

Subject: test

Thread-Topic: test

Thread-Index: AQHXmQQk2OJfeNmnxUKPKY5PdPX0Jg==

Date: Tue, 24 Aug 2021 16:21:49 +0000

Message-ID: <1f4c13a46c164fdbbe497b034fbab3d2@yoush.it>

Accept-Language: en-GB, en-US

Content-Language: en-GB

X-MS-Has-Attach:

X-MS-TNEF-Correlator: <1f4c13a46c164fdbbe497b034fbab3d2@yoush.it>

x-originating-ip: [192.168.x.126]

MIME-Version: 1.0

Return-Path: email@diomain.suffix

X-CrossPremisesHeadersFilteredBySendConnector: EDGEsrv.domain.suffix

X-OrganizationHeadersPreserved: EDGEsrv.domain.suffix

Sponsor

Want to thank us? Use: Patreon or PayPal or Bitcoins: 12G4A52Znm5s35buKDEmKU2p2vQY69Nsyo

All opinions expressed within these pages are sent in by members of the public or by our staff in their spare time, and as such do not represent any opinion held by sircles.net Ltd or their partners.

sirclesadmin
11 months ago
See if there is an issue here: Office 365 Mail Flow Insights 

Try sending from O365 to your Exchange server accounts and replying.

It could be that the address is still stored in X.500 routing and you need to overwrite it or delete it from the Outlook profile.

If you just retype the whole address and do not accept any suggestions then that may fix it.

Replying to the O365 emails may fix it.

Otherwise add an Exchange connector to the Edge Exchange server type internal and point it at your mail record from MXToolbox.com and enter the specific domain as the source domain with the Office 365 MX record as the destination and that should sort it out.

You will need to be careful that both online and on-premises accounts receive the messages.