Welcome Guest! To enable all features please Login or Register.



Go to last post Go to first unread
#1 Posted : 09 November 2017 06:40:36(UTC)

Rank: Administration

Groups: Administrators
Joined: 03/10/2016(UTC)
Posts: 71

We were seeing a message in the top corner of Outlook:

waiting for a page to be retrieved from a Microsoft Dynamics 365 Server


waiting for a page to be retrieved from a Microsoft Dynamics 365 Server

Depending on your Outlook/CRM version.

And the viewing pane simply stated:
"We didn't find anything to show here."

So now pages fail to render in Outlook 2010-16.

This turns out to be a security patch that has been added to counter issues with the Outlook customised roaming home page - nice of them to mention it. The October 2017 update that has been added to Microsoft Office Outlook prevents showing this page and so the system waits forever instead of producing any kind of useful message.

This effects every Outlook Dynamics plug-in as they all rely on the home page to be shown.

This update cannot be removed as it addresses a serious security flaw in the application, so the following registry workaround must be used:

To create a .reg file, use:

Microsoft Outlook 2016:

[HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Security] "EnableRoamingFolderHomepages"=dword:00000002

Microsoft Outlook 2013:

[HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Outlook\Security] "EnableRoamingFolderHomepages"=dword:00000002

Microsoft Outlook 2010:

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Security] "EnableRoamingFolderHomepages"=dword:00000002

You will not need admin rights on the system you are using to make these changes as they are within your own user profile - this can be updated as a script at user login.

Just restart Outlook following the change...

If you wish to use Regedit to make these changes:

Press [Windows Button] + R

type Regedit and click OK

You will see:


In the left pane expand HKEY_CURRENT_USER > Software > Office >

Then look for the version number corresponding to the Outlook for which you are seeing the problem:

Outlook 2016 = 16.0
Outlook 2013 = 15.0
Outlook 2010 = 14.0

As so:

Regedit for Outlook version

Then continuing from the corresponding version number, expand Outlook > Security

Now right click on the yellow Security folder (known as a 'Key' in the registry) and choose New > DWORD

Like so:

Regedit create new DWORD

Name the new DWORD EnableRoamingFolderHomepages

Regedit DWORD EnableRoamingFolderHomepages

Once created, double click the EnableRoamingFolderHomepages DWORD to open the properties:

Enter DWORD Value

Enter the value of 2 and press enter, you may now close the registry editor (RegEdit.exe)

Then restart restart Outlook to see the effects.

You may also use these links:


to download a file to fix the issue for each corresponding version of Office

Edited by user 22 November 2017 11:17:10(UTC)  | Reason: More explanation

#2 Posted : 27 November 2017 14:43:51(UTC)

Rank: Newbie

Groups: Registered
Joined: 27/11/2017(UTC)
Posts: 1

I've looked in the far corners of the web for a fix - and nothing worked.

Saw this reg edit and thought it might be worth a shot. Then when browsing to the reg key it was missing, so then I thought as I have over the years when creating the folder and key - this will never work!

But - it does, it really does!

#3 Posted : 27 November 2017 16:30:23(UTC)

Rank: Advanced Member

Groups: Registered
Joined: 08/01/2017(UTC)
Posts: 199
United Kingdom
Location: London

How did you find this- I've been stuck with this for ages on our MS CRM 2016 system?

Anyway thanks for posting - we added the add reg to a login script and that solved 99% of the issues but a few we had to do manually...
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.